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V Introduction

In this introductory course, you will become familiar with and comfortable in the Maple 10 environment. You will lean
how to use context menus, task assistants, and palettes to perform powerful analyses and create high-impact graphics
with only a minimal knowledge of commands. You will also learn how to create technical reports that capture the
knowledge behind an analysis directly in the Maple document. This course will give you the tools you need to get
started quickly, and a solid foundation upon which to build your future Maple explorations.

To try this material on your own, start with an empty Maple document. Perform the steps found in the left column of
each table below. The results of each step are displayed in the right column for your reference.

Note for non-Windows users: The keystrokes given in this document are for Windows. There will be differences for
other platforms. If you are using a different platform, see Help > Quick Help for the list of the most common
keystrokes.

V¥V Talking to Maple

In this section, you will learn the basics of asking Maple a question and getting a result.

Steps Results

Using [ENTER]

When you launch Maple you start with a blank document,
with menus and toolbars at the top, palettes on the side.
At the cursor, you can start typing math. Press [ENTER]

to see the result.
1+2

Example: Type "1+2 [ENTER]". 3
Notice that the result appears on the next line.

Using [Ctrl] [=]

In the example above, we obtained a result by pressing
[ENTER] after our input.

You can also get Maple to return the result on the same
line as your question by typing [Ctr1l] [=] (hold down
the control key, then press the = key).

Example. Type "x+5-2"then [Ctrl] [=].




x+ 5-2=x+3

Context Menus

You can use Maple's context menus to perform a wide
variety of mathematical and other operations.

Example: Place your cursor on the last result, and right-
click. The context menu offers several operations to
choose from according to the expression that you are
using. To integrate this expression, select Integrate, then
X.

Example: To plot the result of the integration, right-click
on the result, and then select Plots > 2-D Plot.

x+ 5-2=x+3 > %x2+3x

x+ 5-2=x+4+3 — %x2+3x—>
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Changing the Problem

Mathematics in a Maple document are /ive. You can go
back, make changes, and re-execute the problem to obtain
a new result.

Example. Go back to your original calculation of "
1 + 2", change the number "1" to a "3" and press
[ENTER]. Note the change in output.

Example:. In the context menu example, above, change
the "x" to ""10 x" ". "Highlight the entire line, including
the plot, then click the execute button, J , found at the

top of the Maple worksheet. All selected calculations are
updated.

3+2

10x + 5-2=10x+3 > 5x +3x —
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Tip: Clicking on the "execute all" button, JjJ , recalculates the entire document.

Entering Math

There are a number of methods to enter math into Maple. You can enter math using a combination of palettes,
keyboard shortcuts, context menus and commands. Most operations can be entered in more than one way, so you can

pick the method you are most comfortable with.

Steps

Result

Exact Answers and Numeric Approximations

Maple calculates exact answers (i.e. fractions remain as
fractions).

Example: On a new line, enter 1/2 + 1/3.

Note that the / automatically moves you to the
denominator. The right-arrow will take you out. Press
[Ctrl] [=] to see the result on the same line.

Maple also calculates numeric approximations.
Example: Right-click the above result and select
Approximate from the context menu. Select accuracy of
5 digits.

If your problem uses decimal approximations already,
Maple will return the answer in the same format.
Example: Try the example on the right.

1,1 _5
St = 083333

0.5x+ %x =0.8333333333 x

Palettes

Maple has over 1000 palette symbols within the 20
palette menus. You can also use Maple's expression




palette to input data. The expression palette contains fill-
in-the-blank templates for common operations.

Example: Use the Expression Palette, find the integral of
4-£ +sin (#)dz. Open the expression palette (click on
"Expression" on the left-hand side of your Maple
document) and click the indefinite integral button. An

indefinite integral template will appear in your
worksheet. Fill in the place-holders (use [TAB] to move
to the next placeholder). When done, press [ENTER] to
evaluate.

Note: Use " to create a superscript, and right-arrow to get
out again.

Example: Use the expression palette to find the limit of a
function.

J4 AL+ sin(t)dt

% 17—005(1)

Sin(xz) _
x—0 X

Symbol Recognition

You can use the symbol recognition palette to find the
symbol you want.

1
Example: Enter % , then use the context menu to

approximate the result to 5 digits. Open the symbol
recognition palette, sketch the "approximation" symbol,
and press the Recognize button. Drag the new symbol to
your worksheet to replace the arrow.

100 33.333

100 33.333

Symbol Completion

The symbol completion mechanism provides an
alternative to palettes for entering symbols.

Type the first few characters of the symbol name, and
press [Ctrl] [Space]. Choose the symbol you want
from the list.

2
Example: Try entering © + Jx
To enter w, typepi [Ctrl] [Space].
For+/ x, enter sgrt [Ctrl] [Space].

T 4+Jx
T +Jx

Case-Sensitivity

Maple is case-sensitive.

Example: Enter "x + x". x+x=2x
Example. Enter"y + Y " y+Y=y+7Y
Compare the results.

Implicit Multiplication

Maple understands implicit multiplication.

Example: Type "3 x" for "3 times x". 3x+5x=8x




To multiply two variables, use a space.

"x vy " means "x times y", but " xy " means the variable
whose name is "xy".

Example: Type "x [ space]y + xy".

If you choose to Differentiate using the context menu,
you will see thatx, y, and xy are treated as three separate
variables due to the way they were entered.

You should be careful using implicit multiplication in
Maple to avoid confusion with function calls. To us,

f(x + 1) looks like a function call, and x(x + 1) looks like
implied multiplication. Maple understands both of these
as function calls.

x(x+2)
X

Example. Enter using no space, a space, and

an explicit multiplication sign. Ask Maple to calculate
each result so you can see the differences.

When multiplying with brackets you can use a space to
achieve implicit multiplication, but it is usually safest to
explicitly use the multiplication symbol.

xy + xy=xy-+txy

fx+1)=f(x+1)

x(x+2) _ x(x+2)
X X

x x+2) _ 19
X

X (x+2) o
X

Mathematical Notation
Maple understands familiar mathematical notation.

For example, Maple understands that y"+y'+y=01s a
differential equation in y(x).

Example. Enter the equation listed above (using the
single quote key for the prime notation). To verify that it
is in fact a differential equation, select Solve DE from the
context menu.

Label References
Maple uses label references.

Whenever you use [ENTER] to get a response, the result
is automatically given a label reference. To refer to a
previous result in a computation, use [Ctr1l] [L] and
enter the label reference number.

Example. Multiply the result (from above) by x,

using labels.

T 4Jxx

(Tl:z+\/?)x

Maple Commands

You can always enter Maple commands by typing them
directly. Examples of Maple commands will be found
throughout this course.

Example: A common command is the assignment
statement, := (colon equals).

Note: Anything you want Maple to evaluate (e.g..

valuel = 5x

value? = 4 x

valuel + value2

5x



assignment statements), must be entered in Math mode.

Anything entered in Text mode will be non-executable. o

Tip: Find the list of keyboard shortcuts for your platform. Click Help > Quick Help menu, and select Math Editor
 Shortcuts.

¥V Combining Text and Math

In Maple you can combine math and text in the same paragraph to help formulate mathematical sentences.

Steps Result

1 1

Example: Start by entering a simple computation. J P43 de =4+ L Baay

4 3

: 3,2 _1 4, 1 3
Go back to the start of your computation (place the cursor | The 1ntegraljx T +3 dre= n + 3 +3x

to the left of your expression), press [ F5]to change from
math input to text input, and start typing text.

You can also input text in place of the equals sign (=). The integral J Y4243 deis equal to
Click on the equals sign and replace it with some
additional text. 1 4 + 1 Y43y

4 3

Place your cursor at the end of the output, press [F5], and | Tpe integral J YA+ +x+3 dris equal to
complete the rest of the sentence.
1 1

" S 3 4 % ¥ +3x, as you can plainly see.

Modify some of the terms in the problem, highlight the The integral J Y452 +x+3 dris equal to
entire sentence and press the  p  button to re-execute the |
. 5 1

4 3 2 :
computation. " + 3 X + o + 3 x, as you can plainly see.

Tip: Pressing [F5]allows you to easily toggle between math input and text input.
Tip: To check what mode you are in, look at the top left of the toolbar.

In text mode it will look like Math -
In math mode it will look like Teut M )

You can also use these buttons to change modes as an alternative to pressing F5.
Tip: Another visual cue is the cursor. When in text mode, the cursor appears as a vertical bar. In math mode, the cursor
s slanted and italic.

V Expressions, Functions and Procedures

Maple handles Functions, Expressions, and Procedures differently.

Steps Result

Expressions

f is an expression in x defined to the right. 2

f1is not a function. f=x 5
X

Example: See the example on the right for what happens
when you try to evaluate f(3).

Example: To find the value of fat a given value of x, you



need to evaluate fat that point. You can do this with

f

Example: Try evaluating G at (1,2) and at (1, y).

Note: this can be extended for use with multi-paramater
functions.

a) context menus *
b) or the eval command — 9 when x=3

eval(f, x=3);

9

Functions

F=x—- x2

2
F is a function in x defined to the right. Note the x=x
difference to how f'was defined above (to create the
arrow, type the "dash" key followed by the "greater than"
key: ->). F'is the function that mapsx to . F(3)=9
2

To find the value of F at a particular value, call the Fy)=y
function F' with an argument.
Example: Try to evaluate F at 3, and F aty.
Multi-Parameter Functions

G = (a,b) > a—b

2,3

G is a 2 parameter function defined to the right. (a,b)—a"=b
You can evaluate G at specified points. G(1,2)=-7

G(l,y)=1-’

Procedures

A function is a special form of the more general
procedure.

Example: See the example on the right for a very basic
procedure.

Procedures can include conditional statements, iteration,
type checking, local variables, error-handling and other
features of standard languages. For an introduction to
Maple programming, see Chapter 8 of the User Manual.

Tip: Use [Shift] [ENTER] to continue a command on
the next line.

procG = proc(a, b)

az—|—b2

end proc

procG(1,2)

proc(a, b) a”2 + b2 end proc

Solving Equations

Maple can solve equations and inequalities for their unknowns.

Steps

Result




Defining Equations

When defining an equation in Maple, you should use the
= sign for equality.

Example: Solve the equation "a - FHbx4+c=0" |a-+b-x+c=0—

for x using the context menu Solve for a Variable. | b=Sbdac ] [x 1 b+ [02—4 0 e
a ' 2

=y p

|

Solving for Exact Solutions

Note that your solution is displayed with an exact
solution by default.

2 X +6-x-3=0—

Example: Solve the equation "2 - X+6:x-3=0" _ 3 1 = _ 3 1 ==
for x using Solve from the context menu. {x——z + 2 15 }’ {x——z 2 15 }

Solving for Numeric Solutions

If you desire a numeric solution, you must specify it

directly.
Example. Using the example above, solve the equation 2246 -x-3=0
using the context menu, this time select Solve _ B
Numerically. — {x=-3.436491673}, {x=0.4364916731}
Solving with Maple Commands solve(2 - x* +6 -x-3=0,x)
3 1 3 1
Note that the equivalent Maple commands are solve and 5 TV 15, 5 T,V 15

fsolve (floating-point solve).

fsolve(2 - 24653, x)
—3.436491673, 0.4364916731

Assigning Equations to Variables

Note that you can assign equations to names. Remember
to use "colon equals" for assigning.

eqn == y=m-x+b

Example. Assign the variable name "eqn" to the equation y=mx-+b
rhs(eqn)

"y =mx + b". Then apply the command "rhs" to your mx4+b
variable name.

V Units

Maple provides the most comprehensive package in the software industry for managing units and dimensions. Over
500 standard units are recognized by the Maple Units package.

Steps Result

Assigning Units




Use the Units palettes to define values with units. Units
(SI) is the metric palette, Units (FPS) is the imperial
palette (foot pound second).

Example:

Enter "Length:= 250.00"

", click on the Units palette, and select "m".

Repeat for Mass and Time.

Type "Force:= Length*Mass/Time"2" and press [Enter].

To simplify the units in this expression, select Units >
Simplify from the context menu of the result.

Length = 250.00[[m]]

250.00 [[m]]
Mass := 500.00[b]]

500.00 [[/5]
Time :=25[s]

25 [Is]
Force = Length: Z;lass
Time
200.0000000 ] [/5]

s

— 90.71847400 [N]]

Units Package

If the Units package is loaded, simplifications are
automatic. (More information on Maple packages can be
found in the Worksheet Mode section, below.)

Example:

Type "with (Units[Standard]) :" and press
[ENTER] to load the Units package.

Then enter the above equation for Force and press
[ENTER].

Note that the unit simplification is done automatically.

with(Units[ Standard]) :
_ Length- Mass
Force .= )
Time
90.71847400 [NV]

Changing Units

You can use the context menu to replace one unit with
another.

Example: Right-click on the value assigned to Length.
Select Units > Replace Units. Change the meters to
centimeters in the length.

Length == 250.00 [m]]
250.00 ]

— 25000.00 [[cn1]

Converting Units

You can also use the context menu to convert units from
one system to another.

Example. Right-click on the value assigned to Mass.
Select Units > Convert > System > SI to convert the
mass from pounds to kilograms.

Mass :=500.00[b]]
500.00 [[/5]

— 226.7961850 [kg]]

Using Tolerances

You can use the Tolerances package to calculate values
with tolerances. This presents answers with the
plus/minus notation.

with(Tolerances) :

Length :=250.00 + 1.0 [[m]
(250. £ 1.00) [[m]]

Mass :=500.00 + .5 [Ib]



!rfxamg;le..th s v ENTER] (500. £ 0.500) [[76]]
ype "with (Tolerances) :" and press [ ] to Time =25 + 3[s]

load the package.
After eafh of tﬁe unit amounts, type "pm [Ctrl] (25. £ 3)[s]
[Space]" to create the + sign and input the tolerance | fppce = Length- Mass

amount. Time*

Now recalculate the answer for Force given the specified (94.8 +22.9)[N]
tolerance levels.

.~ Tip: For an overview of the unit facilities, see units.

V¥ Data Structures: Lists, Sets, Sequences, Vectors and Matrices

Maple provides a variety of basic data structures, including lists, sets, sequences and matrices, arrays and tables.
Different Maple commands return their results inside different data structures, as appropriate to the problem. It is
important to become familiar with the basic structures and how they differ, so you can manipulate them properly and
choose the most appropriate structure for your problem. This section covers the basics of the most common data
structures.

Steps Result

Lists

Lists are ordered elements. Use square brackets when
entering data in lists.

Example: Input the list [a,b,c,a] and assign it to the mylist == [a, b, c, a]

variable name mylist. [a, b, c, a]

Use square brackets to access a particular element.

Example: Retrieve the 3rd item in mylist. mylist[3]

Sets

Sets contain elements but remove repeated elements and
do not respect order. Use curly braces for defining sets.
Example: Input a set and assign it to the variable name myset = {x, x-y, x- % », X% X}
myset. {y, Xy, xyz, xz
Standard set operations work as expected. y 3
Example: Using the symbol recognition palette to find the | myset N {x°, x’}

set intersection sign, find the intersection of myset and { xz}
{x* X}
The following notation is unreliable:
Square bracket notation can be used to extract elements of | ;)e7[ 1 ]

a set, but should only be used in an interactive session 2
where you can see myset. You cannot use this notation

programmatically, as the order of elements in a set may
change from session to session.

Other commands are available to extract elements from
sets, such as remove and select. You can always convert a
set to a list, if guaranteed order is needed.

Sequences

A sequence is any collection of objects separated by
commas.
The seq command creates sequences. myseq = seq( 2 i=1.10)




Example: Enter a sequence which has the value of i for
i=1..10.

Square bracket index notation can also be used for
sequences.

Example: Retrieve the 3rd item from the sequence
defined above.

1,4,9, 16, 25, 36, 49, 64, 81, 100

myseq|[3 ]

Vectors

A vector is NOT the same thing as a list, though they
look similar. A vector is a special datatype.

Example: Create a vector from the Matrix palette, setting
one of the dimensions to one.

Example. Define a vector by using the Vector command.

myvector :=[ 8 69 99 29]
[ 8 69 99 29 |

Vector[column]([1,2,3])

1
: . 2
Square bracket index notation can also be used for
vectors. 3
Example: Retrieve the 3rd item from the sequence torl3
defined above. myvector(3] 99
Matrices
A matrix is a rectangular array of elements, set out in
rows and columns. 32 4 8 99
mymatrix =
Example: Use the Matrix palette to create a matrix. You —74 27 69 29
can fill in the values yourself, or select Random from the 32 4 g 99
Type drop-down box of the Matrix palette.
—714 27 69 29
You can also use the Matrix() command, to create
matrices. _
Example. See the example on the right. Matrix ( [ [ 1,2,3 ]9
[4.5.6]]);
123
Use indexing to access individual elements. 4 5 6
Example. Use indexing to retrieve the value from the st
row, 3rd column of mymatrix and assign it to a variable
name. element == mymatrix[ 1, 3]
Example: Use indexing to retrieve the 1st and 2nd values 8
from the 1st row, of mymatrix. mymatrix[ 1, 1.2]
[ 32 4]
The map command
Th d avoli functi i ) map(x - xz, mymatrix)
e map command applies a function to every element 1n 1024 16 64 9801

a list, set, vector matrix, etc. See examples to the right.

5476 729 4761 841

map(j — . mylist);



[, b°, &, ]

V¥ Working with Matrices

Maple can perform a number of operations with matrices.

Steps Result
Creating a Matrix

124
Example: Use the Matrix palette to create a random 3x3
matrix. Tab between the placeholders and fill in the 342
values. 4 5 3
Matrix Calculations with the Context Menu

[ -1 T

Use the context menu to perform matrix calculations. - -5 3

124 22
Example. 340 1 13 5 -
Select Standard Operations > Inverse to find the | 3 4 2 - 4
inverse. 453 3
Select Standard Operations > Determinant to find the 1r = 1
determinant. 4 4 2
Multiplying Matrices

, , o 44 31 || 8 99 —1787 3457
Example: To multiply two matrices by implicit =
multiplication, place them side-by-side. | 92 67 || 69 29 5359 11051
f;znghlee You can also multiply matrices explicitly by 98 57 |[ -38 g7 2698 —6645
period (.) as the matrix multiplication symbol. =77 27 [| —18 33 2440 —5808
Multiplying by a scalar
. . 93 72 93b -72b

Example: To multiply a matrix by a scalar, use the . =
multiplication symbol. =76 2 76 b 2b

such as Gaussian Elimination.

_ linear algebra problems.

Tip: Linear algebra tutors can be found in the Tools > Tutors > LinearAlgebra menu, for stepping through problems

Tip: The LinearAlgebra package contains many commands for manipulating matrices and vectors and for solving

menu.

Example: Enter an expression in x (e.g.. sin’ (x)), right-
click on the expression, and select Plots > 2-D Plot.

V Plotting
Maple can produce 2-D and 3-D plots of equations and expressions.
Steps Result
2-D Plots
Now we will demonstrate plotting in Maple. The fastest
way to plot an expression in Maple is to use the context sinz(x) -



Example. Use the point probe to find the coordinates of
different points in the graph. Click on the plot, then move
the cursor to different locations. The coordinates are
displayed in the top left of the plot toolbar.

Example: To pan the plot, right-click on the plot, and
select Manipulator>Pan. Hold down the left mouse
button and use the mouse to move the plot around. To
scale the plot, perform the same steps, but select
Manipulator>Scale.

Tip: You can also change the manipulator tool by
clicking on the plot, and then selecting the appropriate

tool from the drop-down toolbar button at the top of the
Maple window:

&
vlx
&

_9

a1

D.5T

Combining Plots

You can easily add another plot on the same set of axes.

Example: Enter another equation in x (e.g.. sin (% )),

highlight the new expression with your mouse, hold
down the [Ctr1]key and drag it onto the plot.

sinz(x) —

-10

sin(%)

3-D Plots

sin(x) -y —




You can also create 3-D plots.

Example: Enter an expression in x and y (e.g.. sin(x) + y)
. Right-click on the expression and use Plots > 3-D Plots
> x,y from the context menu.

Example: Rotate the plot by clicking on the plot, holding
down the left mouse button and moving the mouse.

Example: Pan and scale the plot by selecting a different
tool from the Manipulator list on the context menu.
Now when you hold down the mouse button and move
the mouse, the new action is performed.

Tip: You can also change the manipulator tool by
clicking on the plot, and then selecting the appropriate

tool from the drop-down toolbar button at the top of the
Maple window:

S
z-
2
&

Plot Options

You can modify the look of your plot in a variety of
ways.

Plot options can be changed by right-clicking on the plot
and modifying the options within the context menu. Note
that the choices available in the context menu are specific
to 3-D plots.

Example. Right-click on the plot to obtain the context
menu. Click Transparency and modify the plot
transparency.

Plot options can also be changed by clicking on the plot,
selecting the Plot toolbar at the top of your Maple
worksheet, and selecting the relevant options.

Example: Click on the image, from the toolbar select Plot
> Axes > Boxed.

sin(x) -y —
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V Task Assistants and Tutors

As explored above, context menus are one way to solve problems without using Maple commands. Task assistants

provide another method. Tutors are useful for teaching and exploring mathematical concepts.
The full list of assistants and tutors can be found on the Tools menu.

Steps

Result




Using the Plot Builder Assistant
. . . o e
Plots can easily be created in Maple using the built-in
Plot Builder. My Plot

Example. Enter the expression you want to plot. From
the context menu, select Plots > Plot Builder. Using the
Plot Builder, you can choose the kind of plot you want,
add titles, and set options, all at once. This example
shows the use of plot title, normal axes and style of
patch with contours.

The Plot Builder allows you to create more than just
ordinary 2-D and
3-D plots. The example on the right is a contour plot.

Example: Enter the expression &+ yz. Select Plots >
Plot Builder from the context menu. Select 2-D Contour
Plot from the Select Plot Type list box, then click Plot.

You can also create an animation using the Plot Builder
assistant.

Example. Enter the expression on the right, right-click to
invoke the context menu.




Select Plots > Plot Builder > select Animation from the
Select Plot Type drop-down list, and click the Plot
button.

Now click on the plot image - some new, plot-specific,
buttons will appear at the top left of your worksheet.
Click the Play button " > " and watch the animation.

Using the ODE Analyzer Assistant
Another useful Maple assistant is the ODE Analyzer.

Example. Enter the differential equation on the right.

Select Solve DE Interactively from the context menu of

this differential equation.

* Under Conditions, click Edit to add initial conditions,
such as y(0)=0 and y'(0)=1

3

iy" +y'+y=sin(x) —

* Select Solve Numerically 0.5
* Press Plot y
00T TTT 7T T NI T T T7TT]
0 2.5 5.0 5 10.0
X
-0.5
Using Tutors in Maple

Maple provides several tutors which are useful for
teaching and exploring mathematical concepts in the
subjects of:

* Precalculus

* Calculus - Multi-Variable

* Calculus - Single-Variable

* Vector Calculus

* Linear Algebra




Example. From the menu, select Tools > Tutors >

Enter a function and follow the example through by
applying the correct rule at each step and using the "Get
Hint" button for help.

Calculus - Single Variable > Differentiation Methods.

V¥ Worksheet Mode

» Command prompt is displayed.

Worksheet mode is an alternative to document mode. The key differences between the two modes are:

* Commands used by context menu operations are shown as they are executed.
» Always use [ENTER] to evaluate expressions. All output appears on next line.

You can also have your whole document in Worksheet
mode. Select File > New > Worksheet Mode. You will
see a red prompt.

Example. Enter an assignment statement, a := 5, and
press [ENTER]. The result is returned, and a new
prompt appears.

Steps Result
Working in Worksheet Mode [ >
Click on the [> button to get into Worksheet mode. [> 24y
Example: Using the context menus, differentiate 4+ x Xt x
Notice that the diff() command is shown on the next line. [> d iﬁp(xz +x, x)
2x+1

1-D versus 2-D Math

If you prefer to enter your commands in 1-D math, use

"Text" mode. Because you are at a command prompt,
Maple knows to evaluate the expression when you press
[ENTER].

x"2+x with respect to x.

warning.

Example: Try it and see.

[F5] or the Math toolbar button to toggle to 1-D

Example: enter the command on the right to differentiate

In 1-D, you must end the command with semi-colon (in 2
-D, it is not needed). If you forget, Maple will give you a

> diff (x*2+x,x);

B 2x+1
> diff (x*3-2*x,x)
Warning, inserted missing semicolon at

end of statement

2

3x" -2

(>

To enter non-executable text in worksheet mode, you

must create a text region. This region can contain 2-D
mathematics notation, but the mathematics will not be
executable.

Toggling Between Text and Math in Worksheet Mode

(Find the derivative of x* + x° - sin (x).



Example: Click the T button on the toolbar to create a

to switch in and out of math mode for the 2-D 4 +2x sin(x) + x° cos(x)
mathematics.

Right-click on the expression in your text region and find
the derivative with respect to x. The diff command and
answer are displayed at a new command prompt.

text region. Type the text shown on the right. Use [F5] [> diff ( P sm (x), x)
L

>

Document Mode within a Worksheet

You can create a mini-document mode inside your
worksheet. This can be used to start a fresh Document
mode section of your document, or it can be used to hide
calculations and commands.

Find the derivative of x* +x* - sin (x).
Example. In the example above, select (highlight) the
text, input, and output entirely, then select Format >

3 . 2
Create Document Block. 4x° +2xsin(x) +x° cos(x)

(>

To see inside the document block, place your cursor in
the visible text and select View > Expand Document
Block.

Tip: When working with Document blocks, turn on
markers by clicking View > Markers. Markers let you
see the start and finish of document blocks.

Entering Maple Commands in Worksheet Mode

Many commands are grouped together in packages. You
can type the long name, or enter a with() command prior
to using a command from that particular package.

Example: Create a Matrix, M, and apply the command i 23
LinearAlgebra[ Determinant](M) to find the determinant || -~ 7 .=
of M. 3 4
23
M=
3 4
> LinearAlgebra[ Determinant](M);
-1
Note: Maple returns an unknown answer when using the :> Determinant(M);
command on it's own (without the package name). ’ ) 3
Det J t
You can avoid having to type the long-form of each erermman ( 3 4 ]

command by pre-loading the desired package. Youcan |-
use a colon at the end of the command to suppress output
or use a semi-colon to see the commands contained in the
package.

Example: Load the LincarAlgebra package first using a > with(LinearAlgebra) :
colon. Try replacing the colon with a semi-colon after the [> Determinant(M);
with command to see the difference.

Example: Now calculate the Determinant of M using the
short-form of the command.

Command completion is very useful when typing out (> GaussianElimination (M);
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long command names.

Example. Type Gau, then press[Ctrl] [Space] to see
a list of possible completions. Use the arrow key to
select the desired command and press [Enter].

(>

Word Processing Tools

Maple contains numerous word processing tools to help you create professional-looking reports. For your reference,

here is a list of some of the more common ones.

Feature

Where to Find It

Built-in title and headings styles

Drop-down list on toolbar

Sections and subsections

Insert > Section, Insert > Subsection

Tables

Insert > Table

Sketch regions

Insert > Sketch

Font control and ability to define new styles

Toolbar buttons, Format > Styles...

Ability to insert images, spreadsheets and other objects

Insert > Image
Insert > Object

A spell-checker aware of mathematical terms

Tools > Spellcheck

Hyperlinks and bookmarks

Format > Convert to > Hyperlink
Format > Bookmarks...

Page numbers

Format > Page Numbers...

Export to HTML

File > Export

Configuring the Maple Environment

You can customize the Maple environment in many ways. Below is a list of the most common ones.
Note that any option set through the Options menu can be set just for this session, or globally (every time you start

Maple).

Feature

How to Control Feature

Start-up dialog.

Turn it off by clearing the check box on the dialog.
Turn it on always by Tools > Options, Interface tab.
See it anytime by Help > Startup Dialog...

Quick Help displayed on new documents.

Turn it off by clearing the check box on the quick help.
Turn it on again by Tools > Options, Interface tab.
See it anytime by pressing [F1] .

Option for new documents to start in Document mode (no
prompt, context menu commands hidden) or Worksheet
mode (prompts, all commands shown).

Tools > Options, Interface tab.
Default format for new worksheets...

Option to enter math in 2-D (default) or 1-D? (Note:
Choice only available in worksheet mode. All math must
be entered in 2-D in document mode.)

Tools > Options, Display tab
Input Display...

> x2
vs.

£> x"2;
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You can also control the input type for individual lines,
without changing the overall default.

[Use context menu on the line above. Selecting Convert
to > 2-D Math Input turns the above line into:

[> xz;

Number of digits displayed in calculation results.
Maple displays 10 digits by default (though it calculates
with more).

Tools > Options, Precision tab
Round screen display to..

For example, show the floating point value of . The
default result is:

> evalf (m);
3.141592654

[After setting the screen display to 5, the result is:
> evalf (7);

3.14159

Palettes can be reordered, and individual palettes can be
moved from one dock to the other, or turned off
completely.

Palette docks can also be expanded and collapsed.

View > Palettes > Arrange Palettes...

Use the View > Palettes menu, or the small arrows at the
top of the palette to expand and collapse. For the left-
hand-side dock, these arrows are in the top-right corner of
the palette, to the right of the scroll bar.

Getting Help

Maple has an extensive help system, including help pages, online manuals, an integrated dictionary of mathematical an

engineering terms, examples, and tutorials.

Steps

Useful for

Select the Help > Maple Help menu to display the help
browser. Enter the topic name (e.g.. "fourier") into the
search box.

Search and browse full help system, including help pages,
dictionary and manuals.

To get help on a particular topic, use the ? notation. E.g. ?
int

If topic name already appears in your document, place the
cursor on the word and press [F2].

Instant access to the help page when you know the topic
name or command name.

Press [F1] for Quick help. Follow links for full
explanations.

Instant help on common tasks.

Help > Quick Reference Card (or [Ctr1] [F2])

Succinct overview of important topics.

?examples,index

Example documents illustrating different mathematical
and programming commands.

Tools > Task > Browse for task templates.

Fill-in-the-blank templates. Organized by concept, not
command name.

Printed manuals are included with the product. The
Getting Started Guide and User Manual are also available
through the help system. Select Help > Manuals,
Dictionary, and more>Manuals to view the manuals.

Conceptual overviews, more in-depth explanations.

Help > Take a Tour of Maple for introductions to topics
and example applications.

Quick introduction to a variety of Maple topics in slide-
show format.



| | Examples of polished interactive technical documents.

¥V Example of a Polished Maple Document

We have now covered the basics. Here is an of how it all fits together.

Tip: You can find more information on using embedded components in Maple documents in the Tips & Techniques
~section of the Application Center (hitp://www.maplesoft.com/applications/app_center_view.aspx?ATD=T1857).



http://www.maplesoft.com/applications/app_center_view.aspx?AID=1408
http://www.maplesoft.com/applications/app_center_view.aspx?AID=1857



